CVE-2026-45660: statamic cms · Server-Side Request Forgery (SSRF)
Affects statamic cmsSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 6.18.1 or 5.73.22 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.18.1, 5.73.22
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 29 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade cms to 6.18.1 or 5.73.22; statamic/cms to 5.73.22.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| statamiccms | Affected
| Fixed in
|
| statamiccms | Affected
| Fixed in
|
GitHubstatamic/cmspkg:github/statamic/cmsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in Statamic CMS versions 5.73.22 and 6.18.1. Users should upgrade to these versions or later to remediate the issue. Additionally, sites running PHP 8.3 or newer are not affected. No other mitigation steps are indicated by the vendor advisory.
Description
A Server-Side Request Forgery (SSRF) vulnerability exists in Statamic CMS versions prior to 5.73.22 and 6.18.1. The Glide image proxy URL validation could be bypassed using non-normalized IP representations, allowing unauthenticated users to make HTTP requests to internal network addresses, including loopback, private networks, and cloud metadata endpoints. This affects sites that pass user-supplied URLs to Glide. Sites running PHP 8.3 or newer are not affected. The vulnerability has a medium severity with a CVSS score of 5.