CVE-2026-45685: open-telemetry opentelemetry-ebpf-instrumentation · Improper Input Validation
Affects open-telemetry opentelemetry-ebpf-instrumentationSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 0.9.0 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.9.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade opentelemetry-ebpf-instrumentation and open-telemetry/opentelemetry-ebpf-instrumentation to 0.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| open-telemetryopentelemetry-ebpf-instrumentation | Affected
| Fixed in
|
GitHubopen-telemetry/opentelemetry-ebpf-instrumentationpkg:github/open-telemetry/opentelemetry-ebpf-instrumentationOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade opentelemetry-ebpf-instrumentation to version 0.9.0 or later, where this vulnerability has been patched. Patch status is confirmed by the vendor advisory indicating the fix in version 0.9.0. No other mitigations are specified.
Description
OpenTelemetry eBPF Instrumentation provides eBPF instrumentation based on the OpenTelemetry standard. From version 0.1.0 to before version 0.9.0, malformed MongoDB wire messages can trigger uncaught panics in the MongoDB TCP parser, allowing a remote unauthenticated attacker to crash the telemetry agent and cause a denial of service. The parser operates on raw attacker-controlled network payloads before the input is fully validated, so a single crafted message can terminate telemetry collection for the affected process or node. This issue has been patched in version 0.9.0.