Skip to main content
VulnerabilityPublished

CVE-2026-45690: nextcloud security-advisories · Improper Authentication

Affects nextcloud security-advisoriesSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 33.0.3 or 32.0.9 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 33.0.3, 32.0.9
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade security-advisories and nextcloud/server to 33.0.3 or 32.0.9.

Affected software

ProductAffectedFixed in
nextcloudsecurity-advisoriesAffected
  • >=33.0.0 <33.0.3
Fixed in
  • 33.0.3
nextcloudsecurity-advisoriesAffected
  • >=32.0.0 <32.0.9
Fixed in
  • 32.0.9
GitHubnextcloud/serverpkg:github/nextcloud/serverOther threatsAffected
  • >=32.0.0 <32.0.9
  • >=33.0.0 <33.0.3
Fixed in
  • 32.0.9
  • 33.0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. It is recommended to upgrade Nextcloud Server to version 32.0.9 or 33.0.3 or later. For Nextcloud Enterprise Server, upgrade to versions 33.0.3, 32.0.9, 31.0.14.5, 30.0.17.9, or 29.0.16.16. No other mitigation steps are indicated by the vendor advisory.

Description

Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 32.0.0 to before 32.0.9, and 33.0.0 to before 33.0.3, an authentication bypass vulnerability allowed attackers with knowledge of a user's password to circumvent two-factor authentication (2FA) protections. When a user initiated login with valid credentials on a 2FA-enabled account, the system created a temporary session token before enforcing the second factor challenge. This token could be extracted and replayed via HTTP Basic Authentication to gain unauthorized access to authenticated endpoints. It is recommended that the Nextcloud Server is upgraded to 33.0.3 or 32.0.9. It is recommended that the Nextcloud Enterprise Server is upgraded to 33.0.3, 32.0.9, 31.0.14.5, 30.0.17.9 or 29.0.16.16

References

Community reviews

Loading reviews…