Skip to main content
VulnerabilityPublished

CVE-2026-45727: CloakHQ CloakBrowser · Path Traversal

Affects CloakHQ CloakBrowserSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 0.3.28 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.3.28
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade CloakBrowser and cloakhq/CloakBrowser to 0.3.28.

Affected software

ProductAffectedFixed in
CloakHQCloakBrowserAffected
  • <0.3.28
Fixed in
  • 0.3.28
GitHubcloakhq/CloakBrowserpkg:github/cloakhq/CloakBrowserOther threatsAffected
  • <0.3.28
Fixed in
  • 0.3.28

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in CloakBrowser version 0.3.28. Users should upgrade to version 0.3.28 or later to remediate the issue. Until upgrading, restricting network access to the cloakserve port can reduce exposure. Patch status is not explicitly stated beyond the fixed version; users should verify with the vendor advisory for any additional guidance.

Description

CVE-2026-45727 is a path traversal vulnerability in CloakHQ's CloakBrowser versions prior to 0.3.28. The cloakserve CDP multiplexer improperly uses a user-supplied fingerprint parameter as a filesystem path component without validation. This allows an unauthenticated attacker who can access the cloakserve port to craft a fingerprint value that traverses directories outside the intended data directory. As a result, when Chrome fails to start or the process is cleaned up, arbitrary directories outside the intended scope can be deleted. The service is exposed by default on all network interfaces (0.0.0.0), increasing exposure risk.

References

Community reviews

Loading reviews…