CVE-2026-45770: OISF suricata · Protection Mechanism Failure
Affects OISF suricataSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 8.0.5 soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.0.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade suricata and oisf/suricata to 8.0.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OISFsuricata | Affected
| Fixed in
|
GitHuboisf/suricatapkg:github/oisf/suricataOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Suricata to version 8.0.5 or later, which contains a fix for this vulnerability. If upgrading immediately is not possible, disable the 'security.lua.allow-rules' setting to prevent loading Lua rules, mitigating the risk of exploitation.
Description
CVE-2026-45770 affects Suricata versions 8.0.0 up to but not including 8.0.5. A vulnerability exists where a Lua rule registering too many flow variables can corrupt the Lua detection state and bypass Suricata's restricted Lua sandbox. This may also cause Suricata to crash. The issue requires an affected Lua script or rule to be loaded. Version 8.0.5 includes a fix, and disabling 'security.lua.allow-rules' is a recommended workaround if Lua rules are not needed.