Skip to main content
VulnerabilityPublished Updated

CVE-2026-46393: haxtheweb haxcms-nodejs · Server-Side Request Forgery (SSRF)

Affects haxtheweb haxcms-nodejsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 26.0.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade haxcms-nodejs and haxcms-php to 26.0.0.

Affected software

ProductAffectedFixed in
haxthewebhaxcms-nodejsAffected
  • <26.0.0
Fixed in
  • 26.0.0
haxthewebhaxcms-phpAffected
  • <26.0.0
Fixed in
  • 26.0.0
npmhaxcms-nodejspkg:npm/haxcms-nodejsOther threatsAffected
  • <26.0.0
Fixed in
  • 26.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade haxcms-nodejs to version 26.0.0 or later, which contains a fix for this SSRF vulnerability. No other official remediation or temporary fixes are indicated. Patch status is confirmed by the vendor advisory stating the fix is in version 26.0.0.

Description

HAX CMS helps manage microsite universe with PHP or NodeJs backends. An authenticated Server-Side Request Forgery (SSRF) vulnerability in versions prior to 26.0.0 allows authenticated users to fetch arbitrary internal or local resources and write the responses to a web-accessible directory, enabling arbitrary file read and internal network access. Version 26.0.0 contains a fix.

References

Community reviews

Loading reviews…