Skip to main content
VulnerabilityPublished Updated

CVE-2026-46397: haxtheweb haxcms-php · Path Traversal

Affects haxtheweb haxcms-phpSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 26.0.0 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.0.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade haxcms-php and haxcms-nodejs and haxtheweb/haxcms-php to 26.0.0.

Affected software

ProductAffectedFixed in
haxthewebhaxcms-phpAffected
  • <26.0.0
Fixed in
  • 26.0.0
haxthewebhaxcms-nodejsAffected
  • <26.0.0
Fixed in
  • 26.0.0
GitHubhaxtheweb/haxcms-phppkg:github/haxtheweb/haxcms-phpOther threatsAffected
  • <26.0.0
Fixed in
  • 26.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade haxcms-php to version 26.0.0 or later, where this vulnerability is patched. No other official remediation or temporary fixes are documented. Until upgraded, restrict access to the saveOutline endpoint to trusted users only.

Description

HAX CMS helps manage microsite universe with PHP or NodeJs backends. Prior to version 26.0.0, an Authenticated Local File Inclusion (LFI) vulnerability in the HAXCMS saveOutline endpoint allows a low-privileged user to read arbitrary files on the server by manipulating the location field written into site.json. This enables attackers to exfiltrate sensitive system files such as /etc/passwd, application secrets, or configuration files accessible to the web server (www-data). Version 26.0.0 patches the issue.

References

Community reviews

Loading reviews…