Skip to main content
VulnerabilityPublished Updated

CVE-2026-46399: haxtheweb haxcms-nodejs · External Control of System or Configuration Setting

Affects haxtheweb haxcms-nodejsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.4 Critical : upgrade to 26.0.0 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade haxcms-nodejs and haxcms-php and haxtheweb/haxcms-nodejs to 26.0.0.

Affected software

ProductAffectedFixed in
haxthewebhaxcms-nodejsAffected
  • <26.0.0
Fixed in
  • 26.0.0
haxthewebhaxcms-phpAffected
  • <26.0.0
Fixed in
  • 26.0.0
npmhaxtheweb/haxcms-nodejspkg:npm/haxtheweb/haxcms-nodejsOther threatsAffected
  • <26.0.0
Fixed in
  • 26.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to HAX CMS PHP version 26.0.0 or later, which patches this vulnerability. No other mitigation details are provided. Patch status is confirmed by the vendor advisory indicating the fix in version 26.0.0.

Description

HAX CMS helps manage microsite universe with PHP or NodeJs backends. The PHP version of HAX CMS prior to version 26.0.0 has an authenticated file overwrite vulnerability. An attacker can exploit this vulnerability to configure malicious Git filter commands and achieve code execution on the HAX CMS server. Version 26.0.0 patches the issue.

References

Community reviews

Loading reviews…