CVE-2026-46440: FlowiseAI Flowise · Insufficiently Protected Credentials
Affects FlowiseAI FlowiseSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 3.1.2 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.2
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Flowise and flowiseai/Flowise to 3.1.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FlowiseAIFlowise | Affected
| Fixed in
|
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Flowise to version 3.1.2 or later, where this vulnerability has been patched. Since the vendor advisory confirms the issue is fixed in 3.1.2, applying this official fix is the recommended remediation.
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.1.2, the checkBasicAuth endpoint validates credentials in plaintext without rate limiting and with direct comparison. This issue has been patched in version 3.1.2.