Skip to main content
VulnerabilityPublished Updated

CVE-2026-46471: Buffer Over-read in GStreamer Gst-plugins-good

Affects gst-plugins-goodSource CVE Database V5

0

Not known to be exploited · CVSS 5.5 Medium : upgrade to 1.28.2 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Affects
GStreamer gst-plugins-good before 1.28.2
Patch
Available – fixed in 1.28.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gstreamer/gst-plugins-good to 1.28.2.

Affected software

ProductAffectedFixed in
GitHubgstreamer/gst-plugins-goodpkg:github/gstreamer/gst-plugins-goodOther threatsAffected
  • <1.28.2
Fixed in
  • 1.28.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GStreamer gst-plugins-good version 1.28.2. Users should upgrade to version 1.28.2 or later to remediate this vulnerability. No other mitigation guidance is provided.

Description

A heap buffer over-read vulnerability exists in the isomp4 plugin of GStreamer gst-plugins-good before version 1.28.2. The issue occurs during MP4 file parsing in the qtdemux_parse_uuid function, potentially allowing an attacker to disclose heap memory contents. This vulnerability has a medium severity rating with a CVSS score of 5.5.

References

Community reviews

Loading reviews…