Skip to main content
CVE-2026-1933VulnerabilityPublished Updated

Red Hat Security Advisory: OpenShift Container Platform 4.18.54 bug fix and security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-1933· High 7.1

Not known to be exploited · CVSS 7.1 High · fixed in Red Hat package updates : patch Red Hat samba soon.

Data as of 26 Oct 2026, 18:42 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.18.54
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Red Hatredhat/sambapkg:rpm/redhat/sambaOther threatsAffected
  • =9.0.0
  • <=9.8
  • >=10.0.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users of Red Hat OpenShift Container Platform 4.18 should upgrade to version 4.18.54 or later, which contains the security fixes for the listed vulnerabilities. Updates are available through the appropriate release channels and can be applied using the OpenShift CLI (oc) or the web console. Detailed upgrade instructions are provided in the official Red Hat documentation. No additional mitigations are specified beyond applying the update.

Description

Red Hat OpenShift Container Platform 4.18.54 includes multiple security fixes addressing vulnerabilities in components such as samba, sssd, gnutls, vim, kernel openvswitch, glibc, and libsolv. These vulnerabilities range from missing access checks, privilege escalation, denial of service, arbitrary code execution, authentication bypass, information disclosure, to heap buffer overflows. Users of OpenShift Container Platform 4.18 are advised to upgrade to the updated packages and images to mitigate these issues.

References

Community reviews

Loading reviews…