CVE-2026-46580: Eclipse Theia · Untrusted Functionality Inclusion
Affects Eclipse TheiaSource CVE Database V5
Not known to be exploited · CVSS 8.4 High : upgrade to 1.71.0 soon.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.71.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Eclipse Theia to 1.71.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Eclipse FoundationEclipse Theia | Affected
| Fixed in
|
GitHubEclipse Theiapkg:github/Eclipse TheiaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, avoid opening untrusted or suspicious workspaces in Eclipse Theia versions prior to 1.71.0. Restrict workspace sources to trusted repositories to prevent loading malicious prompt templates.
Description
Eclipse Theia versions prior to 1.71.0 automatically load files matching the pattern .prompts/*.prompttemplate from a workspace, which can override or extend AI agent system prompts. This behavior allows an attacker to craft a malicious repository that replaces the AI's system instructions with attacker-controlled content, leading to indirect prompt injection. Exploitation combined with other AI chat features in untrusted workspaces can result in data exfiltration via Markdown image rendering or arbitrary command execution via task definitions. The vulnerability has a high severity with a CVSS score of 8.4.