Skip to main content
VulnerabilityPublished Updated

CVE-2026-4660: HashiCorp Tooling · Information Exposure

Affects HashiCorp ToolingSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 1.8.6 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.8.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade HashiCorp Tooling to 1.8.6.

Affected software

ProductAffectedFixed in
HashiCorpToolingAffected
  • <1.8.6
Fixed in
  • 1.8.6
GitHubToolingpkg:github/ToolingOther threatsAffected
  • <1.8.6
Fixed in
  • 1.8.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in go-getter version 1.8.6. Users should upgrade to version 1.8.6 or later to remediate this vulnerability. The go-getter/v2 branch is not affected and does not require action. Refer to the Red Hat advisories for additional guidance and updates.

Description

HashiCorp’s go-getter library up to v1.8.5 may allow arbitrary file reads on the file system during certain git operations through a maliciously crafted URL. This vulnerability, CVE-2026-4660, is fixed in go-getter v1.8.6. This vulnerability does not affect the go-getter/v2 branch and package.

References

Community reviews

Loading reviews…