Skip to main content
VulnerabilityPublished

CVE-2026-46605: Apache ActiveMQ Broker · Improper Authorization

Affects Apache ActiveMQ BrokerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.3 Medium : upgrade to 6.2.6 or 5.19.7 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.2.6, 5.19.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache ActiveMQ Broker and Apache ActiveMQ All and Apache ActiveMQ and Apache Software Foundation/org.apache.activemq:activemq-broker and Apache Software Foundation/org.apache.activemq:activemq-all and Apache Software Foundation/org.apache.activemq:apache-activemq to 6.2.6 or 5.19.7; org.apache.activemq/activemq-broker to 5.19.7.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ActiveMQ BrokerAffected
  • >=6.0.0 <6.2.6
Fixed in
  • 6.2.6
Apache Software FoundationApache ActiveMQ BrokerAffected
  • <5.19.7
Fixed in
  • 5.19.7
Apache Software FoundationApache ActiveMQ AllAffected
  • >=6.0.0 <6.2.6
Fixed in
  • 6.2.6
Apache Software FoundationApache ActiveMQ AllAffected
  • <5.19.7
Fixed in
  • 5.19.7
Apache Software FoundationApache ActiveMQAffected
  • >=6.0.0 <6.2.6
Fixed in
  • 6.2.6
Apache Software FoundationApache ActiveMQAffected
  • <5.19.7
Fixed in
  • 5.19.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache ActiveMQ Broker to version 5.19.7 or 6.2.6, where this authorization issue has been fixed. No other mitigation or temporary workaround is indicated. Patch status is confirmed by the vendor advisory recommending these versions.

Description

Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authenticated connections to remove existing destinations with proper permissions. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version v6.2.6 or v5.19.7, which fixes the issue.

References

Community reviews

Loading reviews…