Skip to main content
VulnerabilityPublished Updated

CVE-2026-46620: e107inc e107 · Improper Authorization

Affects e107inc e107Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.3.5 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.3.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade e107 and e107inc/e107 to 2.3.5.

Affected software

ProductAffectedFixed in
e107ince107Affected
  • <2.3.5
Fixed in
  • 2.3.5
GitHube107inc/e107pkg:github/e107inc/e107Other threatsAffected
  • <2.3.5
Fixed in
  • 2.3.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade e107 CMS to version 2.3.5 or later, where this vulnerability is fixed. Since the vendor advisory confirms the fix in 2.3.5, applying this official update is the recommended remediation. No other mitigation guidance is provided or necessary.

Description

e107 CMS versions prior to 2.3.5 have an improper authorization vulnerability related to CSRF token validation on comment moderation actions. The session_handler::check() function only validates CSRF tokens if one is present, skipping validation entirely if no token is provided. This allows unauthorized state-changing requests to potentially succeed. The vulnerability is fixed in version 2.3.5. The CVSS score is 6.5, indicating a medium severity level.

References

Community reviews

Loading reviews…