CVE-2026-55573 is a critical deserialization vulnerability in the e107 content management system prior to version 2.3.7. The vulnerability exists in install.php, which unserializes attacker-controlled data without restricting allowed classes, enabling unauthenticated remote code execution. This flaw allows an attacker to execute arbitrary PHP functions with the web server's privileges, potentially leading to full server compromise. The issue is fixed in version 2.3.7.
CVE-2026-55572 is a critical SQL injection vulnerability in the e107 content management system prior to version 2.3.7. It affects the bundled alt_auth plugin's otherdb and e107db authentication backends, which interpolate the submitted login username directly into SQL queries without proper sanitization. This allows unauthenticated attackers to inject SQL commands when alt_auth is installed and configured with a live external database connection. The vulnerability can lead to exposure or modification of data accessible by the database account and may disclose query details through debug messages. The issue is fixed in e107 version 2.3.7.
e107 is a content management system (CMS). Versions 2.3.5 and earlier contain a command injection vulnerability in the ImageMagick resize destination path. In resize_image(), the source path is escaped with escapeshellarg(), but the destination path is inserted inside raw double quotes in the convert command; in the submit-news upload flow, that destination filename includes the first six characters of user-controlled news title input. Because the title filter removes literal spaces but not tab characters, and shell expansions such as $(...) and backticks can survive into the quoted destination argument, /bin/sh -c may evaluate attacker-controlled input. Exploitation is possible only when all of the following non-default settings are enabled: resize_method=ImageMagick, subnews_attach=1, upload_enabled=1, subnews_resize is numeric between 30 and 5000, and the attacker is a non-admin in classes permitted by both subnews_class and upload_class. This issue has been fixed in version 2.3.6.
e107 CMS versions prior to 2.3.5 have an improper authorization vulnerability related to CSRF token validation on comment moderation actions. The session_handler::check() function only validates CSRF tokens if one is present, skipping validation entirely if no token is provided. This allows unauthorized state-changing requests to potentially succeed. The vulnerability is fixed in version 2.3.5. The CVSS score is 6.5, indicating a medium severity level.
e107 is a content management system (CMS). Prior to 2.3.4, a Host Header Injection vulnerability in the password reset page allows attackers to manipulate the Host header to generate password reset links pointing to attacker-controlled domains. This can lead to phishing attacks, account takeover, or other security risks. The severity is high, as the vulnerability affects a critical function related to user authentication. This vulnerability is fixed in 2.3.4.
e107 is a content management system (CMS). Prior to 2.3.4, a Broken Access Control vulnerability exists in the application, allowing an unauthorized authenticated user to edit comments posted by others. This stems from inadequate server-side access control validation, where the application depends only on a predictable identifier in the request to determine which comment to edit, without confirming the requesting user’s ownership of the comment. This vulnerability is fixed in 2.3.4.
e107 is a content management system (CMS). Prior to 2.3.4, you can access the local environment by specifying the URL of the local environment from "Image/File URL:" of "From a remote location" in "Media Manager" on the administrator screen. This vulnerability is fixed in 2.3.4.