CVE-2026-43935: e107inc e107 · Improper Input Validation
Affects e107inc e107Source CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 2.3.4 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.3.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade e107 and e107inc/e107 to 2.3.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| e107ince107 | Affected
| Fixed in
|
GitHube107inc/e107pkg:github/e107inc/e107Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade e107 to version 2.3.4 or later, where this vulnerability is fixed. Since this is a self-hosted CMS, administrators must apply the update manually. Patch status is confirmed by the vendor's versioning information. No additional mitigations are specified.
Description
e107 is a content management system (CMS). Prior to 2.3.4, a Host Header Injection vulnerability in the password reset page allows attackers to manipulate the Host header to generate password reset links pointing to attacker-controlled domains. This can lead to phishing attacks, account takeover, or other security risks. The severity is high, as the vulnerability affects a critical function related to user authentication. This vulnerability is fixed in 2.3.4.
References
- github.com/e107inc/e107/security/advisories/GHSA-7pmw-jwvr-cq2x (opens in a new tab)
- github.com/e107inc/e107/commit/04511f9f1d6e97c31ba7cc5bf7f1f9a19d221db6 (opens in a new tab)
- github.com/e107inc/e107/commit/b0dee8234e273debbf7a8ae054de464f1008f357 (opens in a new tab)
- github.com/e107inc/e107/commit/c4f9f71b0fd695545d0f09e2277b6f70ff4660fc (opens in a new tab)