Skip to main content
VulnerabilityPublished

CVE-2026-46752: Apache Kvrocks · Heap-based Buffer Overflow

Affects Apache KvrocksSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 10.0 Critical · fixed in 2.16.0 : patch Apache Kvrocks as a priority.

Data as of 7 Nov 2026, 23:24 UTC

CVSS 4.0 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.16.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache KvrocksAffected
  • >=2.0.4 <=2.15.0
Fixed in–

AI-suggested

Users should upgrade Apache Kvrocks to version 2.16.0 or later, where this heap-based buffer overflow vulnerability in the cjson library has been fixed. No other remediation or temporary mitigations are indicated. Patch status is confirmed by the recommendation to upgrade to 2.16.0.

Description

Redis Lua HEAP overflow in cjson library vulnerability in Apache Kvrocks. This issue affects Apache Kvrocks: from 2.0.4 through 2.15.0. Users are recommended to upgrade to version 2.16.0, which fixes the issue.

References

Community reviews

Loading reviews…