Skip to main content
VulnerabilityPublished

CVE-2026-54226: Apache Kvrocks · Integer Overflow Leads to Remote DoS

Affects Apache KvrocksSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.4 Medium · fixed in 2.16.0 : update Apache Kvrocks when convenient.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 4.0 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.16.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:L/SC:H/SI:H/SA:H/S:N/AU:N/R:I/V:D/RE:L/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache KvrocksAffected
  • >=2.6.0 <=2.15.0
Fixed in–

AI-suggested

Users should upgrade Apache Kvrocks to version 2.16.0 or later, where this integer overflow vulnerability is fixed. Patch status is confirmed by the vendor's recommendation to upgrade. No additional mitigation steps are specified.

Description

A vulnerability in Apache Kvrocks. This issue affects Apache Kvrocks: from 2.6.0 through 2.15.0. Users are recommended to upgrade to version 2.16.0, which fixes the issue.

References

Community reviews

Loading reviews…