Skip to main content
VulnerabilityPublished

CVE-2026-47074: ex_aws_sns · Improper Certificate Validation

Affects ex_aws_snsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 2.3.5 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.3.5, 1853d280b152d10384a1e21a22cf22152a60be48
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade ex_aws_sns and ex_aws/ex_aws_sns to 2.3.5; ex_aws_sns to 1853d280b152d10384a1e21a22cf22152a60be48.

Affected software

ProductAffectedFixed in
ex-awsex_aws_snsAffected
  • >=2.0.1 <2.3.5
Fixed in
  • 2.3.5
ex-awsex_aws_snsAffected
  • ≥ a7ec21880943f4dac1d59bda557db0ffcd2b61fa, < 1853d280b152d10384a1e21a22cf22152a60be48
Fixed in
  • 1853d280b152d10384a1e21a22cf22152a60be48
Hexex_aws/ex_aws_snspkg:hex/ex_aws/ex_aws_snsOther threatsAffected
  • <2.3.5
Fixed in
  • 2.3.5
Hexex_aws_snspkg:hex/ex_aws_snsOther threatsAffected
  • >=2.0.1 <2.3.5
Fixed in
  • 2.3.5

CPE configurations (1)

  • cpe:2.3:a:ex_aws_sns_project:ex_aws_sns:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch addressing this vulnerability is available. Since ex_aws_sns is a cloud service, the vendor typically manages remediation server-side. Users should verify with the vendor advisory to confirm that the patch has been applied. No additional action is required if the vendor has already mitigated the issue.

Description

CVE-2026-47074 is a high-severity vulnerability in the ex-aws ex_aws_sns library affecting versions from 2.0.1 up to but not including 2.3.5. The issue involves improper certificate validation in the SNS message verification process, where the SigningCertURL is not properly checked to ensure it uses HTTPS or belongs to an AWS-owned domain. This flaw allows attackers to spoof SNS message signatures by supplying a malicious SigningCertURL, potentially causing forged SNS messages to be accepted as valid. A patch is available, and since this is a cloud service, the vendor typically manages remediation server-side. No known exploits are reported in the wild at this time.

References

Community reviews

Loading reviews…