Skip to main content
VulnerabilityPublished Updated

CVE-2026-47117: maziyarpanahi openmed · Code Injection

Affects maziyarpanahi openmedSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 1.5.2 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 60% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade maziyarpanahi/openmed and openmed to 1.5.2.

Affected software

ProductAffectedFixed in
maziyarpanahiopenmedAffected
  • <1.5.2
Fixed in–
GitHubmaziyarpanahi/openmedpkg:github/maziyarpanahi/openmedOther threatsAffected
  • <1.5.2
Fixed in
  • 1.5.2
GitHubopenmedpkg:github/openmedOther threatsAffected
  • <1.5.2
Fixed in
  • 1.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Since the vulnerability affects OpenMed versions prior to 1.5.2, upgrading to version 1.5.2 or later is recommended once an official fix is released. Until then, restrict access to the model loading functionality and avoid using untrusted model_name inputs to mitigate risk.

Description

OpenMed before 1.5.2 contains a remote code execution vulnerability in the PII privacy-filter model loading path. The privacy-filter dispatcher used broad substring matching on the user-supplied model_name parameter, allowing a value such as attacker/foo-privacy-filter-bar to route through a path that loads Hugging Face models with trust_remote_code=True. An unauthenticated attacker can supply a malicious model repository containing custom Transformers code via auto_map in config.json or tokenizer_config.json, which is imported and executed with the privileges of the OpenMed service process.

References

Community reviews

Loading reviews…