CVE-2026-47137: patriksimek vm2 · Improper Control of Dynamically-Managed Code Resources
Affects patriksimek vm2Source CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 10.0 Critical : upgrade to 3.11.4 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.11.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade patriksimek vm2 to 3.11.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| patriksimekvm2 | Affected
| Fixed in
|
npmvm2pkg:npm/vm2Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix for this vulnerability is available in vm2 version 3.11.4. Users should upgrade to version 3.11.4 or later to remediate this issue. There is no indication that temporary mitigations or workarounds are available or recommended.
Description
vm2 is an open source vm/sandbox for Node.js. Prior to version 3.11.4, the fix for GHSA-8hg8-63c5-gwmx (CVE-2023-37903) introduced a check in nodevm.js line 263 that blocks the combination nesting: true + require: false. However, the check uses strict equality (options.require === false), which is trivially bypassed by omitting the require option entirely. When require is not specified, options.require is undefined, not false. The strict equality check fails, so the security guard is skipped. Immediately after (line 280), the destructuring default require: requireOpts = false assigns requireOpts = false, producing the exact configuration the patch was designed to prevent. This issue has been patched in version 3.11.4.
References
- github.com/patriksimek/vm2/security/advisories/GHSA-m4wx-m65x-ghrr (opens in a new tab)
- github.com/patriksimek/vm2/commit/01a7552add345d5a6862623884e6b79a85bf0568 (opens in a new tab)
- github.com/patriksimek/vm2/commit/86ab819f202c3a8dad88cef5705f2e416c5188d7 (opens in a new tab)
- github.com/advisories/GHSA-g644-9gfx-q4q4 (opens in a new tab)
- github.com/patriksimek/vm2/releases/tag/v3.11.4 (opens in a new tab)