Skip to main content
VulnerabilityPublished

CVE-2026-47139: patriksimek vm2 · Protection Mechanism Failure

Affects patriksimek vm2Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 3.11.4 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.11.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade patriksimek vm2 to 3.11.4.

Affected software

ProductAffectedFixed in
patriksimekvm2Affected
  • <3.11.4
Fixed in
  • 3.11.4
npmvm2pkg:npm/vm2Other threatsAffected
  • <3.11.4
Fixed in
  • 3.11.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade vm2 to version 3.11.4 or later, where this vulnerability is patched. No other mitigation is indicated or required.

Description

vm2 is a Node.js sandbox that prior to version 3.11.4 allowed sandboxed code to bypass network restrictions by accessing internal underscored HTTP modules. Although public network modules could be excluded, internal modules like _http_client and _http_server were not blocked, enabling outbound HTTP requests and listening sockets. This vulnerability is fixed in version 3.11.4.

References

Community reviews

Loading reviews…