Skip to main content
VulnerabilityPublished Updated

CVE-2026-47181: PenguinMod-BackendApi · Improper Input Validation

Affects PenguinMod-BackendApiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 1.0.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade PenguinMod-BackendApi and penguinmod/PenguinMod-BackendApi to 1.0.0.

Affected software

ProductAffectedFixed in
PenguinModPenguinMod-BackendApiAffected
  • <1.0.0
Fixed in
  • 1.0.0
GitHubpenguinmod/PenguinMod-BackendApipkg:github/penguinmod/PenguinMod-BackendApiOther threatsAffected
  • <1.0.0
Fixed in
  • 1.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PenguinMod-BackendApi to version 1.0.0 or later, where this vulnerability has been patched. No other mitigation is indicated by the vendor advisory.

Description

PenguinMod-BackendApi is the backend api for penguinmod. Prior to version 1.0.0, a NoSQL injection vulnerability in the password reset endpoint allows any authenticated user to change the password of an account, leading to full account takeover. An attacker only needs a registered account and a valid password reset token for their own account. This issue has been patched in version 1.0.0.

References

Community reviews

Loading reviews…