CVE-2026-47201: goauthentik authentik · Improper Input Validation
Affects goauthentik authentikSource CVE Database V5
Not known to be exploited · CVSS 8.5 High · fixed in 2026.5.1 : patch goauthentik authentik soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.5.1, 2026.2.3, 2025.12.5
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade authentik and github.com/goauthentik/authentik to 2026.5.1, 2026.2.3 or 2025.12.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| goauthentikauthentik | Affected
| Fixed in
|
| goauthentikauthentik | Affected
| Fixed in
|
| goauthentikauthentik | Affected
| Fixed in
|
Gogithub.com/goauthentik/authentikpkg:golang/github.com/goauthentik/authentikOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in authentik versions 2025.12.5, 2026.2.3, and 2026.5.1. Users should upgrade to one of these versions or later to remediate this vulnerability. Patch status is confirmed by the vendor advisory indicating these versions contain the fix.
Description
authentik is an open-source identity provider. Prior to versions 2025.12.5, 2026.2.3, and 2026.5.1, authentik's SAML Source ACS endpoint is vulnerable to XML Signature Wrapping when validating upstream SAML responses. An attacker with any account at the upstream IdP can reuse a valid signed assertion to authenticate as another federated user. This issue has been patched in versions 2025.12.5, 2026.2.3, and 2026.5.1.