Skip to main content
VulnerabilityPublished

CVE-2026-47202: Kareadita Kavita · Improper Authentication

Affects Kareadita KavitaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 0.9.0.2 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.0.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Kavita and kareadita/Kavita to 0.9.0.2.

Affected software

ProductAffectedFixed in
KareaditaKavitaAffected
  • <0.9.0.2
Fixed in
  • 0.9.0.2
GitHubkareadita/Kavitapkg:github/kareadita/KavitaOther threatsAffected
  • <0.9.0.2
Fixed in
  • 0.9.0.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Kavita to version 0.9.0.2 or later, where this improper token validation vulnerability is fixed. Since the vendor advisory indicates the issue is resolved in this version, applying this official fix is the recommended remediation. No other mitigation steps are specified or required.

Description

CVE-2026-47202 is a critical improper authentication vulnerability in Kavita versions prior to 0.9.0.2. It allows a remote unauthenticated attacker to request a JSON Web Token (JWT) for any user, including administrators, if the attacker knows the username. This flaw stems from improper token validation. The vulnerability has a high CVSS 4.0 score of 9.3, indicating severe impact. A fix is available in version 0.

References

Community reviews

Loading reviews…