Skip to main content
VulnerabilityPublished

CVE-2026-47215: sylabs singularity · Path Traversal

Affects sylabs singularitySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 4.4.2 when convenient.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.4.2, 4.3.9, 4.1.14
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade singularity and sylabs/singularity to 4.4.2; SingularityPRO to 4.3.9 or 4.1.14.

Affected software

ProductAffectedFixed in
sylabssingularityAffected
  • <4.4.2
Fixed in
  • 4.4.2
sylabsSingularityPROAffected
  • >=4.2.0 <4.3.9
Fixed in
  • 4.3.9
sylabsSingularityPROAffected
  • <4.1.14
Fixed in
  • 4.1.14
GitHubsylabs/singularitypkg:github/sylabs/singularityOther threatsAffected
  • <4.4.2
Fixed in
  • 4.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade SingularityCE to version 4.4.2 or later, or SingularityPRO to versions 4.3.9 or 4.1.14 or later to apply the official fix. Systems not using the limit container paths directive are not affected and require no action. No other mitigation is indicated by the vendor advisory.

Description

CVE-2026-47215 is a path traversal vulnerability in Sylabs Singularity container platforms. It affects SingularityCE versions prior to 4.4.2 and SingularityPRO versions prior to 4.3.9 and 4.1.14. The flaw arises from incorrect path-string matching in the limit container paths directive of singularity.conf, allowing containers located in sibling directories outside the configured allowlist to be run under setuid mode. Installations not using the limit container paths feature are not affected. This issue has been fixed in the specified versions.

References

Community reviews

Loading reviews…