Skip to main content
VulnerabilityPublished

CVE-2026-47252: julien040 anyquery · Code Injection

Affects julien040 anyquerySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.0 Critical : upgrade to 0.4.5 as a priority.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 3.1 base score
9.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.4.5, 0.2.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade anyquery and julien040/anyquery to 0.4.5; github.com/julien040/anyquery/plugins/brave and github.com/julien040/anyquery/plugins/chrome and github.com/julien040/anyquery/plugins/edge and github.com/julien040/anyquery/plugins/reminders and github.com/julien040/anyquery/plugins/safari to 0.2.0.

Affected software

ProductAffectedFixed in
julien040anyqueryAffected
  • <0.4.5
Fixed in
  • 0.4.5
anyquerygithub.com/julien040/anyquery/plugins/braveAffected
  • <0.2.0
Fixed in
  • 0.2.0
anyquerygithub.com/julien040/anyquery/plugins/chromeAffected
  • <0.2.0
Fixed in
  • 0.2.0
anyquerygithub.com/julien040/anyquery/plugins/edgeAffected
  • <0.2.0
Fixed in
  • 0.2.0
anyquerygithub.com/julien040/anyquery/plugins/remindersAffected
  • <0.2.0
Fixed in
  • 0.2.0
anyquerygithub.com/julien040/anyquery/plugins/safariAffected
  • <0.2.0
Fixed in
  • 0.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade anyquery to version 0.4.5 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory. Patch status is confirmed fixed in 0.4.5.

Description

Anyquery is an SQL query engine built on top of SQLite. Prior to 0.4.5, authenticated users with INSERT or UPDATE access to affected macOS virtual tables can execute operating-system commands because the Chrome plugin and equivalent Brave, Edge, and Safari variants interpolate a SQL-controlled URL into AppleScript or JXA source passed to osascript. In plugins/chrome/tabs.go, tabsTable.Insert() passes the URL through fmt.Sprintf(newTabScript, url), and tabsTable.Update() uses fmt.Sprintf(setURLScript, pk, url). A URL containing quote and newline characters can break out of the intended string or property record and append script statements, resulting in arbitrary command execution with the privileges of the anyquery process on the macOS host. This issue is fixed in version 0.4.5.

References

Community reviews

Loading reviews…