Skip to main content
VulnerabilityPublished Updated

CVE-2026-47274: mcdope pam_usb · Uncontrolled Search Path Element

Affects mcdope pam_usbSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 0.9.0 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.0
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade pam_usb and mcdope/pam_usb to 0.9.0.

Affected software

ProductAffectedFixed in
mcdopepam_usbAffected
  • <0.9.0
Fixed in
  • 0.9.0
GitHubmcdope/pam_usbpkg:github/mcdope/pam_usbOther threatsAffected
  • <0.9.0
Fixed in
  • 0.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in pam_usb version 0.9.0. Users should upgrade to version 0.9.0 or later to remediate this issue. Until upgraded, restrict local access to trusted users to reduce risk.

Description

pam_usb provides hardware authentication for Linux using ordinary removable media. Prior to 0.9.0, multiple pam_usb helper tools resolved external binaries through the PATH environment variable rather than using absolute paths. An attacker who can influence the process environment during PAM authentication or tool execution could substitute malicious binaries. The affected tools are pamusb-check (src/tmux.c), pamusb-conf (tools/pamusb-conf), and pamusb-keyring-unlock-gnome (tools/pamusb-keyring-unlock-gnome). This vulnerability is fixed in 0.9.0.

References

Community reviews

Loading reviews…