Skip to main content
VulnerabilityPublished

CVE-2026-47741: shopperlabs shopper · Race Condition

Affects shopperlabs shopperSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 2.8.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.8.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade shopper and shopperlabs/shopper to 2.8.0.

Affected software

ProductAffectedFixed in
shopperlabsshopperAffected
  • <2.8.0
Fixed in
  • 2.8.0
GitHubshopperlabs/shopperpkg:github/shopperlabs/shopperOther threatsAffected
  • <2.8.0
Fixed in
  • 2.8.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to shopper version 2.8.0 or later, where this race condition vulnerability is fixed. Patch status is not explicitly stated but the vendor has released version 2.8.0 to address the issue. Until upgrading, merchants should be aware that discount usage limits may be exceeded under high concurrency.

Description

CVE-2026-47741 is a race condition vulnerability in shopperlabs' shopper product prior to version 2.8.0. The issue occurs because the system creates an order before properly checking and incrementing the discount usage counter, allowing the discount's usage limit to be exceeded silently under concurrent checkout conditions. This results in orders being processed with discounts applied beyond their intended usage limits without alerting the merchant. The vulnerability has a medium severity with a CVSS score of 5.9 and is fixed in version 2.8.0.

References

Community reviews

Loading reviews…