Skip to main content
VulnerabilityPublished

CVE-2026-47745: shopperlabs shopper · Missing Authorization

Affects shopperlabs shopperSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.8.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.8.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade shopper and shopperlabs/shopper to 2.8.0.

Affected software

ProductAffectedFixed in
shopperlabsshopperAffected
  • <2.8.0
Fixed in
  • 2.8.0
GitHubshopperlabs/shopperpkg:github/shopperlabs/shopperOther threatsAffected
  • <2.8.0
Fixed in
  • 2.8.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade shopper to version 2.8.0 or later where this authorization issue is fixed. Patch status is confirmed fixed in 2.8.0. Until upgrading, restrict authenticated user permissions to trusted users only to minimize risk.

Description

Shopper is a Headless e-commerce Admin Panel. Prior to 2.8.0, the admin tables for PaymentMethods, Currencies and Carriers exposed inline toggles and per-record actions (enable, disable, edit, delete) that were rendered for any authenticated panel user without checking the corresponding per-action permission. A low-privilege user could disable every payment method on the store, disable or alter the default currency, or disable carriers. The impact is a full denial of checkout and pricing integrity loss, reachable by any authenticated user. This vulnerability is fixed in 2.8.0.

References

Community reviews

Loading reviews…