CVE-2026-47835: Spring AI · Improper Neutralization of Special Elements in Data Query Logic
Affects Spring AISource CVE Database V5
Not known to be exploited · CVSS 8.6 High : upgrade to 1.1.8 or 1.0.9 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.1.8, 1.0.9
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 15 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Spring AI and org.springframework.experimental/spring-ai-elasticsearch-store and org.springframework.experimental/spring-ai-opensearch-store and org.springframework.experimental/spring-ai-gemfire-store to 1.1.8 or 1.0.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SpringSpring AI | Affected
| Fixed in
|
| SpringSpring AI | Affected
| Fixed in
|
Mavenorg.springframework.experimental/spring-ai-elasticsearch-storepkg:maven/org.springframework.experimental/spring-ai-elasticsearch-storeOther threats | Affected
| Fixed in
|
Mavenorg.springframework.experimental/spring-ai-opensearch-storepkg:maven/org.springframework.experimental/spring-ai-opensearch-storeOther threats | Affected
| Fixed in
|
Mavenorg.springframework.experimental/spring-ai-gemfire-storepkg:maven/org.springframework.experimental/spring-ai-gemfire-storeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Fixes are available in Spring AI versions 1.0.9 and 1.1.8. Users should upgrade affected components (spring-ai-elasticsearch-store, spring-ai-opensearch-store, spring-ai-gemfire-store) to these versions or later to remediate the vulnerability. Patch status is not explicitly confirmed in the vendor advisory, but the presence of fixed versions indicates official fixes are available. No alternative mitigations are specified.
Description
In Spring AI Vector Stores, special characters could be used to force the execution of arbitrary queries in Elasticsearch, OpenSearch, and GemFire VectorDB. Affected components: spring-ai-elasticsearch-store, spring-ai-opensearch-store, spring-ai-gemfire-store. Affected versions: Spring AI 1.0.0 through 1.0.x (fix 1.0.9). Spring AI 1.1.0 through 1.1.x (fix 1.1.8).