CVE-2026-48047: xwiki-platform · Path Traversal: '../filedir
Affects xwiki-platformSource CVE Database V5
Not known to be exploited · CVSS 5.9 Medium · fixed in 17.10.3 : update xwiki-platform when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.10.3, 17.4.9, 16.10.17
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade xwiki-platform and org.xwiki/xwiki-platform to 17.10.3, 17.4.9 or 16.10.17.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| xwikixwiki-platform | Affected
| Fixed in
|
| xwikixwiki-platform | Affected
| Fixed in
|
| xwikixwiki-platform | Affected
| Fixed in
|
Mavenorg.xwiki/xwiki-platformpkg:maven/org.xwiki/xwiki-platformOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability has been patched in XWiki versions 16.10.17, 17.4.9, 17.10.3, and 18.0.0RC1. Users should upgrade to one of these versions or later. No other workarounds are known, so it is important to restrict admin and script rights carefully to trusted users only.
Description
XWiki Platform WebJars API is a package for XWiki, a generic wiki platform. Starting with version 9.6-rc-1 and prior to versions 16.10.17, 17.4.9, and 17.10.3, a potential path traversal vulnerability allow an attacker who manages to get a malicious WebJar extension installed on the wiki to write arbitrary files. While the consequences could be severe like overriding configuration files and setting the superadmin password, the attack first requires that the attacker already has admin access to at least a subwiki to be able to install a malicious extension. Further, the attacker needs to publish a malicious extension in an extension repository that is configured in the instance. This vulnerability has been patched in XWiki 16.10.17, 17.4.9, 17.10.3, and 18.0.0RC1. XWiki is not aware of any workarounds except for being careful whom developers grant script and admin rights to.