CVE-2026-48065: mcdope pam_usb · Heap-based Buffer Overflow
Affects mcdope pam_usbSource CVE Database V5
Not known to be exploited · CVSS 6.7 Medium : upgrade to 0.9.1 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.9.1
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade pam_usb and mcdope/pam_usb to 0.9.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| mcdopepam_usb | Affected
| Fixed in
|
GitHubmcdope/pam_usbpkg:github/mcdope/pam_usbOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade pam_usb to version 0.9.1 or later, where this vulnerability is fixed. Since the vendor advisory or patch links are not provided, verify the version in use and apply the official update from the mcdope project to remediate this issue. Patch status is not explicitly confirmed beyond the fix in 0.9.1; check the vendor's official resources for the latest remediation guidance.
Description
A heap-based buffer overflow vulnerability exists in pam_usb versions prior to 0.9.1 due to improper heap memory allocation when processing the number of devices from the configuration file. On 32-bit systems, integer overflow causes an undersized allocation, leading to heap overflow during array writes. This vulnerability has a CVSS score of 6.7 and can impact confidentiality, integrity, and availability. The issue is fixed in version 0.9.1.