Skip to main content
VulnerabilityPublished Updated

CVE-2026-48093: code-embed (WordPress plugin) · Cross-site Scripting

Affects code-embed (WordPress plugin)Source CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.6.1 when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.6.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade code-embed and dartiss/code-embed to 2.6.1.

Affected software

ProductAffectedFixed in
dartisscode-embedAffected
  • <2.6.1
Fixed in
  • 2.6.1
GitHubdartiss/code-embedpkg:github/dartiss/code-embedOther threatsAffected
  • <2.6.1
Fixed in
  • 2.6.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the Code Embed plugin to version 2.6.1 or later, where this vulnerability is patched. Until then, restrict contributor privileges or disable the external URL embed feature to prevent exploitation.

Description

The Code Embed WordPress plugin prior to version 2.6.1 is vulnerable to stored Cross-Site Scripting (XSS) through the external URL embed feature in post content. The vulnerable code scans rendered content for URL embed tokens, fetches the remote URL, and inserts the remote response body into the page without output sanitization or an `unfiltered_html` capability check. This allows a Contributor attacker to submit a pending post containing an inert-looking URL token that executes attacker-controlled JavaScript when an Administrator or Editor previews or reviews the post. This is distinct from CVE-2026-2512, which affected custom field meta values up to version 2.5.1. This vector affects version 2.6 and uses the documented external URL embed feature in post content. This particular issue is patched in version 2.6.1.

References

Community reviews

Loading reviews…