Skip to main content
VulnerabilityPublished

CVE-2026-48097: 0x5t4l1n NexTOR_IP_CHANGER · OS Command Injection

Affects 0x5t4l1n NexTOR_IP_CHANGERSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.8 High : upgrade to 2.0.0 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade NexTOR_IP_CHANGER and 0x5t4l1n/NexTOR_IP_CHANGER to 2.0.0.

Affected software

ProductAffectedFixed in
0x5t4l1nNexTOR_IP_CHANGERAffected
  • <2.0.0
Fixed in
  • 2.0.0
GitHub0x5t4l1n/NexTOR_IP_CHANGERpkg:github/0x5t4l1n/NexTOR_IP_CHANGEROther threatsAffected
  • <2.0.0
Fixed in
  • 2.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to NexTor IP Changer version 2.0.0 or later, where this vulnerability has been fixed. No other official remediation or temporary fixes are documented. Until upgrading, avoid running the tool in environments where the PATH can be manipulated by untrusted users.

Description

NexTor IP Changer is a command-line tool that leverages the Tor network to periodically rotate a user's IP address. Versions prior to 2.0.0 have a command execution vulnerability due to unsafe use of `shell=True` with commands that rely on executable resolution through the `PATH` environment variable. An attacker controlling the execution environment can place malicious executables such as sudo earlier in the `PATH`, resulting in execution of attacker-controlled code. Version 2.0.0 fixes the issue.

References

Community reviews

Loading reviews…