Skip to main content
VulnerabilityPublished Updated

CVE-2026-48115: misskey · Improper Authorization

Affects misskeySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 2026.5.4 when convenient.

Data as of 1 Nov 2026, 11:03 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.5.4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade misskey and misskey-dev/misskey to 2026.5.4.

Affected software

ProductAffectedFixed in
misskey-devmisskeyAffected
  • >=2024.5.0 <2026.5.4
Fixed in
  • 2026.5.4
GitHubmisskey-dev/misskeypkg:github/misskey-dev/misskeyOther threatsAffected
  • >=2024.5.0 <2026.5.4
Fixed in
  • 2026.5.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected Misskey instances to version 2026.5.4 or later, where the improper authorization vulnerability in the Server Announcements API has been fixed. No other mitigation or temporary workaround is documented.

Description

Misskey is an open source, federated social media platform. All Misskey servers running versions 2024.5.0 and later, but prior to 2026.5.4, contain a vulnerability in the Server Announcements API where insufficient permission checks allow attackers to access limited portions of data that they normally couldn't view. This vulnerability occurs whether or not federation is enabled. This issue has been fixed in version 2026.5.4.

References

Community reviews

Loading reviews…