CVE-2026-48116: Mintplex-Labs anything-llm · Command Injection
Affects Mintplex-Labs anything-llmSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 1.13.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.13.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 28 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade anything-llm and mintplex-labs/anything-llm to 1.13.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mintplex-Labsanything-llm | Affected
| Fixed in
|
GitHubmintplex-labs/anything-llmpkg:github/mintplex-labs/anything-llmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in AnythingLLM version 1.13.0. Users should upgrade to version 1.13.0 or later to remediate this issue. Since the vendor advisory does not provide an official patch link or temporary workaround, upgrading is the recommended action. Deployments without the filesystem plugin enabled are not vulnerable. Patch status is not explicitly confirmed beyond the stated fix in 1.13.0; users should verify with the vendor for the latest remediation guidance.
Description
CVE-2026-48116 is a command injection vulnerability in Mintplex-Labs anything-llm versions prior to 1.13.0. The issue arises because the filesystem-search-files agent skill passes an LLM-controlled pattern parameter to ripgrep without using an end-of-options separator, allowing specially crafted patterns to be interpreted as command options. This enables an attacker who can interact with the agent and has the filesystem plugin enabled to execute arbitrary commands inside the server container. The vulnerability is fixed in version 1.13.0.