Skip to main content
VulnerabilityPublished Updated

CVE-2026-48122: Shopify ruby-lsp · OS Command Injection

Affects Shopify ruby-lspSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.4 Medium : upgrade to 0.10.4 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.10.4
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Shopify ruby-lsp to 0.10.4.

Affected software

ProductAffectedFixed in
Shopifyruby-lspAffected
  • <0.10.4
Fixed in
  • 0.10.4

AI-suggested

Upgrade the Ruby LSP VS Code extension to version 0.10.4 or later, which fixes this vulnerability. Avoid opening and trusting repositories from untrusted sources.

Description

Ruby LSP is an implementation of the language server protocol for Ruby. Several workspace-level settings in the Ruby LSP VS Code extension prior to version 0.10.4 could override the path to the Ruby executable, the version manager executables, or the Bundler `Gemfile` used at startup. A malicious repository containing a `.vscode/settings.json` could set these values to attacker-controlled targets. Opening and trusting the repository would then execute code with the privileges of the developer. The Ruby LSP gem and clients of the language server in other editors are not affected. Version 0.10.4 of the Ruby LSP VS Code extension fixes the issue.

References

Community reviews

Loading reviews…