Skip to main content
VulnerabilityPublished Updated

CVE-2026-34060: Shopify ruby-lsp · Code Injection

Affects Shopify ruby-lspSource CVE Database V5

0

Not known to be exploited · CVSS 7.1 High : upgrade to 0.26.9 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.26.9, 0.10.2
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ruby-lsp to 0.26.9; Shopify.ruby-lsp to 0.10.2.

Affected software

ProductAffectedFixed in
Shopifyruby-lspAffected
  • <0.26.9
Fixed in
  • 0.26.9
ShopifyShopify.ruby-lspAffected
  • <0.10.2
Fixed in
  • 0.10.2

AI-suggested

Users should upgrade to Shopify.ruby-lsp version 0.10.2 or ruby-lsp version 0.26.9 or later, where this vulnerability has been patched. No other mitigations are specified or required once patched. Patch status is confirmed by the vendor advisory embedded in the description.

Description

Ruby LSP is an implementation of the language server protocol for Ruby. Prior to Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9, the rubyLsp.branch VS Code workspace setting was interpolated without sanitization into a generated Gemfile, allowing arbitrary Ruby code execution when a user opens a project containing a malicious .vscode/settings.json. This issue has been patched in Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9.

References

Community reviews

Loading reviews…