CVE-2026-45205: Apache Commons Configuration · Uncontrolled Recursion
Affects Apache Commons ConfigurationSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 2.15.0 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.15.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 14 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Apache Commons Configuration and Apache Software Foundation/org.apache.commons:commons-configuration2 and org.apache.commons/commons-configuration2 to 2.15.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Commons Configuration | Affected
| Fixed in
|
MavenApache Software Foundation/org.apache.commons:commons-configuration2pkg:maven/Apache Software Foundation/org.apache.commons:commons-configuration2Other threats | Affected
| Fixed in
|
Mavenorg.apache.commons/commons-configuration2pkg:maven/org.apache.commons/commons-configuration2Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Commons Configuration to version 2.15.0 or later, where this uncontrolled recursion issue is fixed. No other mitigations or temporary workarounds are indicated. Patch status is not explicitly stated in the vendor advisory, but the recommended upgrade version confirms an official fix is available.
Description
An uncontrolled recursion vulnerability exists in Apache Commons Configuration when processing YAML configuration files containing cycles. This can cause a StackOverflowError, leading to a denial of service. The issue affects versions from 2.2 up to but not including 2.15.0. Upgrading to version 2.15.0 resolves the problem.