Skip to main content
VulnerabilityPublished

CVE-2026-48519: langflow · Code Injection

Affects langflowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.6 Critical : upgrade to 1.9.2 as a priority.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
9.6Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.9.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade langflow to 1.9.2.

Affected software

ProductAffectedFixed in
langflow-ailangflowAffected
  • <1.9.2
Fixed in
  • 1.9.2
PyPIlangflowpkg:pypi/langflowOther threatsAffected
  • <1.9.2
Fixed in
  • 1.9.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade langflow to version 1.9.2 or later, where this vulnerability is fixed. No other official remediation or temporary fix is indicated. Users should avoid using vulnerable versions and restrict access to the Shareable Playground feature until patched.

Description

Langflow is a tool for building and deploying AI-powered agents and workflows. Prior to 1.9.2, the "Shareable Playground" (or "Public Flows" in code) contains a critical RCE vulnerability. Shareable Playground feature works by enabling the execution of workflows by unauthenticated users, by accessing a link. Specifically, it enables the route /api/v1/build_public_tmp to execute any public flow, given a public flow ID. When the route executes the flow, it allows for providing arbitrary custom Python code as the nodes code, inside the JSON payload. The vulnerable field is data.nodes[X].data.node.template.code.value. This vulnerability is fixed in 1.9.2.

References

Community reviews

Loading reviews…