Skip to main content
VulnerabilityPublished

CVE-2026-4881: Octopus Server · Insufficient permission checks on an API endpoint

Affects Octopus ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.0 Medium · fixed in 2026.1.11313 : update Octopus Server when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.1.11313, 2025.4.10545, 2025.4.10523
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Octopus Server to 2026.1.11313, 2025.4.10545 or 2025.4.10523.

Affected software

ProductAffectedFixed in
Octopus DeployOctopus ServerAffected
  • >=2026.1.0 <2026.1.11313
Fixed in
  • 2026.1.11313
Octopus DeployOctopus ServerAffected
  • >=2025.4.0 <2025.4.10545
Fixed in
  • 2025.4.10545
Octopus DeployOctopus ServerAffected
  • >=2023.0.0 <2025.4.10523
Fixed in
  • 2025.4.10523

AI-suggested

If you cannot patch yet, restrict access to the Octopus Server API endpoints to trusted users only and monitor for unusual activity related to server-level changes. Avoid granting unnecessary authentication privileges to users.

Description

CVE-2026-4881 is a vulnerability in Octopus Deploy Octopus Server where insufficient permission checks on a specific API endpoint allow any authenticated user to make server-level changes despite receiving an error. This affects multiple versions of Octopus Server and has a medium severity rating with a CVSS score of 6.

References

Community reviews

Loading reviews…