CVE-2026-49107: Thrive Apprentice (WordPress plugin) · Deserialization of Untrusted Data
Affects Thrive Apprentice (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 10.8.10.2 as a priority.
Data as of 30 Oct 2026, 20:25 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.8.10.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Thrive Apprentice (WordPress plugin) to 10.8.10.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Thrive ThemesThrive Apprentice | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to the affected application and monitor for suspicious activity related to deserialization. Avoid exposing the vulnerable service to untrusted networks.
Description
CVE-2026-49107 is a critical vulnerability in Thrive Themes Thrive Apprentice versions prior to 10.8.10.2. It involves unauthenticated PHP Object Injection due to deserialization of untrusted data, classified under CWE-502. This vulnerability allows an attacker to execute arbitrary code without authentication, impacting confidentiality, integrity, and availability.