Skip to main content
VulnerabilityPublished

CVE-2026-49843: signalwire freeswitch · Improper Authentication

Affects signalwire freeswitchSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.11.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.11.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade freeswitch and signalwire/freeswitch to 1.11.1.

Affected software

ProductAffectedFixed in
signalwirefreeswitchAffected
  • <1.11.1
Fixed in
  • 1.11.1
GitHubsignalwire/freeswitchpkg:github/signalwire/freeswitchOther threatsAffected
  • <1.11.1
Fixed in
  • 1.11.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade FreeSWITCH to version 1.11.1 or later, where this vulnerability is patched. There is no indication of alternative mitigations or temporary fixes. Patch status is not explicitly stated but the vendor has fixed the issue in 1.11.1, so upgrading is the recommended remediation.

Description

FreeSWITCH versions prior to 1.11.1 contain an improper authentication vulnerability in the mod_verto JSON-RPC handler. The handler binds connections to client-supplied session IDs before authentication, allowing an unauthenticated attacker who knows a target session UUID to evict legitimate clients by causing session collisions. This results in denial of service for the legitimate client. The issue has been fixed in version 1.11.1.

References

Community reviews

Loading reviews…