Skip to main content
VulnerabilityPublished Updated

CVE-2026-49871: Apache APISIX · Cross-Site Request Forgery (CSRF)

Affects Apache APISIXSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.1 Low · fixed in 3.17.0 : update Apache APISIX when convenient.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 4.0 base score
2.1Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.17.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache APISIXAffected
  • >=3.0.0 <=3.16.0
Fixed in–

AI-suggested

Users should upgrade Apache APISIX to version 3.17.0 or later, where this CSRF vulnerability in the cas-auth plugin is fixed. No other mitigation or temporary workaround is indicated.

Description

Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations. This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity. Actions the victim takes upstream are then attributed to attackers identity. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

References

Community reviews

Loading reviews…