Skip to main content
VulnerabilityPublished Updated

CVE-2026-49975: Apache HTTP Server · Excessive Memory Allocation

Affects Apache HTTP ServerSource CVE Database V5

0
Compare

Not known to be exploited · 32% EPSS · CVSS 7.5 High : upgrade to 2.4.68 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
32.9% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.68
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade apache/httpd to 2.4.68.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache HTTP ServerAffected
  • >=2.4.17 <=2.4.67
Fixed in–
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • >=2.4.17 <2.4.68
Fixed in
  • 2.4.68

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update addressing this vulnerability is available from Red Hat in the JBoss Core Services Apache HTTP Server 2.4.62 Service Pack 4 release. Users should apply this update to remediate the issue. The vulnerability exists in default HTTP/2 configurations; therefore, disabling HTTP/2 or applying vendor-recommended mitigations may reduce exposure if immediate patching is not possible. Refer to the Red Hat security bulletin (RHSA-2026:27200) and Apache advisories for detailed mitigation procedures. No indication that the vulnerability is already mitigated without patching.

Description

Memory Allocation with Excessive Size Value vulnerability in Apache HTTP Server's mod_http leads to denial of service via malicious HTTP requests. This issue affects Apache HTTP Server: from 2.4.17 through 2.4.67.

References

Community reviews

Loading reviews…