Skip to main content
VulnerabilityPublished Updated

CVE-2026-50633: Apache CXF · Improper Input Validation

Affects Apache CXFSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High · fixed in 4.2.2 : patch Apache CXF soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.2, 4.1.7, 3.6.12
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache to 4.2.2, 4.1.7 or 3.6.12.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache CXFAffected
  • >=4.2.0 <4.2.2
Fixed in
  • 4.2.2
Apache Software FoundationApache CXFAffected
  • >=4.0.0 <4.1.7
Fixed in
  • 4.1.7
Apache Software FoundationApache CXFAffected
  • <3.6.12
Fixed in
  • 3.6.12
MavenApache Software Foundation/org.apache.cxf:cxf-integration-jcapkg:maven/Apache Software Foundation/org.apache.cxf:cxf-integration-jcaOther threatsAffected
  • >=4.2.0 <4.2.2
  • >=4.0.0 <4.1.7
  • <3.6.12
Fixed in
  • 4.2.2
  • 4.1.7
  • 3.6.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat advisories indicate that no effective mitigation currently meets their criteria for ease of use, applicability, or stability. The recommended remediation is to upgrade affected Apache CXF versions to 4.2.2, 4.1.7, or 3.6.12 where the vulnerability is fixed. Users should apply these updates as soon as possible. Monitor vendor advisories for any future mitigation options or patches. No other mitigations are currently advised by the vendor.

Description

CVE-2026-50633 is a high-severity JNDI Injection vulnerability in Apache CXF's JCA integration module that allows arbitrary code execution if an attacker can manipulate the JCA deployment descriptor or runtime activation parameters. The vulnerability affects multiple versions of Apache CXF prior to 4.1.7, 4.2.2, and 3.6.12. The attack complexity is high, requiring specific conditions for exploitation. Red Hat products shipping Apache CXF are affected, but no effective mitigation is currently available that meets Red Hat's criteria. Users are recommended to upgrade to fixed versions to remediate the issue.

References

Community reviews

Loading reviews…