Skip to main content
VulnerabilityPublished Updated

CVE-2026-5190: aws-c-event-stream · Out-of-bounds Write

Affects aws-c-event-streamSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 0.6.0 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.6.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade aws-c-event-stream and awslabs/aws-c-event-stream to 0.6.0.

Affected software

ProductAffectedFixed in
AWSaws-c-event-streamAffected
  • <0.6.0
Fixed in
  • 0.6.0
GitHubawslabs/aws-c-event-streampkg:github/awslabs/aws-c-event-streamOther threatsAffected
  • <0.6.0
Fixed in
  • 0.6.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available. Users should upgrade aws-c-event-stream to version 0.6.0 or later to remediate this vulnerability. Since this is a library used in client applications, applying the update is necessary to prevent exploitation.

Description

CVE-2026-5190 is a high-severity vulnerability in the aws-c-event-stream library before version 0.6.0. It involves an out-of-bounds write in the streaming decoder component that could allow a malicious server to cause memory corruption and potentially execute arbitrary code on a client processing crafted event-stream messages. The issue is fixed in version 0.6.0 and later.

References

Community reviews

Loading reviews…