Skip to main content
VulnerabilityPublished Updated

CVE-2026-5241: huggingface/transformers · Untrusted Functionality Inclusion

Affects huggingface/transformersSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.0 High · fixed in 5.5.0 : patch huggingface/transformers soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.0 base score
8.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.0
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
huggingfacehuggingface/transformersAffected
  • ≥ unspecified, < 5.5.0
Fixed in–
PyPItransformerspkg:pypi/transformersOther threatsAffected
  • =5.2.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in huggingface/transformers version 5.5.0 and later, which corrects the handling of the 'trust_remote_code' parameter to prevent override by untrusted configuration data. Users should upgrade to version 5.5.0 or newer to remediate this vulnerability. Currently, Red Hat states that no mitigation meeting their criteria for ease of use, applicability, and stability is available. Therefore, upgrading to a fixed version is the recommended remediation. Avoid loading untrusted LightGlue models until patched.

Description

A vulnerability in the LightGlue model loading path of huggingface/transformers version 5.2.0 allows an attacker-controlled model repository to execute arbitrary code during model initialization. The issue arises because the `trust_remote_code` parameter, intended to prevent remote code execution, is overridden by untrusted serialized configuration data in a nested code path. Specifically, when loading a LightGlue model using `AutoModel.from_pretrained()` with `trust_remote_code=False`, the `LightGlueConfig` reads the `trust_remote_code` value from the untrusted `config.json` file and propagates it into nested `AutoConfig.from_pretrained()` calls. This results in the execution of attacker-provided Python modules, even when the victim explicitly disables remote code execution. The vulnerability poses a high risk for environments such as API inference servers, research notebooks, CI/CD pipelines, and model evaluation workers, potentially leading to credential theft, lateral movement, or persistence/backdoor deployment.

References

Community reviews

Loading reviews…